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Introduction
NOTE: If the sporting event has a specific length, start time, and number of breaks, the sporting event can be set
up as a regular satellite show. This document covers sporting events that have a variable start time, end time,
number of breaks depending on length, each started by closure/trigger (game start trigger, break start trigger, and
game end trigger).
Some sports that are fixed length (no overtime, for instance) and do not have to contend with weather delays or
cancellations can be handled in the same way as syndicated satellite programming. But with sports played
outdoors, such as baseball, football, and road racing (such as NASCAR or F1) or that have the possibility for
overtime require a bit more moving parts to gracefully handle each of these situations.
This document outlines our recommended configuration to handle sports rebroadcasting in a way that easily
handles variable start time, rain delay (by start of game trigger), variable length (by end of game trigger), and a
variable number of breaks with the use of a secondary program log during the game and returning to normal
programming after the game.
NOTE: There are more advanced techniques that allow for simulcasting the normal station content while
broadcasting the sports game, such as when you have an internet stream that cannot broadcast the game for
licensing reasons. This involves using two independent OpX Audio Servers/station profiles. This configuration
is outside the scope of this document.

Overview

In this log creation technique, you will create two (or three) program logs. The first program log will be based
on your normal program log (with a few additions) while the second program log will contain the break content
for the duration of your sports rebroadcast. Optionally, you can create a third log which will be played after your
game is completed. The Alternate Clocks function of the Clock Builder module will be used to set up your log
structure and a Satellite Start event will be used with specific settings (as outlined below) to facilitate handling
the game start, break start, and game end triggers along with the log-switching functions.
During playback, a modified version of your normal day’s log (also referred to as “main log” within this
document) will play. When the game start trigger is received, your currently playing audio content will stop OpX
and activate the sporting event’s satellite show profile, switching the audio channel to the sporting event and
loading the break content to be triggered by the sporting event’s break start closure/trigger. When the sporting
event’s game end closure/trigger is received, your main log will be re-loaded.

Configuring Clock Builder for the Main Program Log
It is recommended that you create your normal full-day’s log for the main program log for the day of the
sporting event. This way, if the game is canceled (e.g. the game start trigger is never executed) your normal
programming will continue as if it were a normal broadcast day. You do, however, need to add a Satellite Show
Start event within your log for the sporting event. You can either modify your normal day’s clocks to account for
this, then un-modify it for use in the future, or you can copy your normal day’s clocks to an alternate clock
(which is what we recommend).
To copy all of the clock hour-blocks from one day to the alternate clocks, perform the following steps:
Open the Clock Builder module (if you have a multi-station installation of OpX, make sure to choose the desired
station profile). Left-click on the Midnight hour-block for your desired day to highlight it. Hold down the
SHIFT key on your keyboard while simultaneously left-clicking on the 11pm hour-block. All hour-blocks for
the day will be selected.Press CTRL-C on your keyboard, which will copy the selected hour-blocks to your
computer’s clipboard.Go to the Edit menu and select Show Alternates, which will switch the grid view from
weekly clocks mode to alternate clocks mode.Left-click on the Midnight hour-block an available alternate
clock.Press Ctrl-V on your keyboard, which will paste the previously copied hour-blocks from step 4. Now that
you have created a copy of your main clock settings in an alternate clock, it is time to modify the clock settings
to include the Satellite Start event for your sports rebroadcast.

Configuring Clock Builder for the Secondary Sporting Event Program
Log
The secondary log will only contain the content (e.g. spots played in the breaks during the sporting event). Use
an unused alternate clock for this configuration. You only need to configure the hour-blocks that apply to the
sporting event. Use the following steps to configure this clock:
Double-click on the hour-block for first hour of your sporting event. Since the first event in a program log is
automatically started, an auto-start cued comment needs to be added as the first event in the log so that the first
break doesn’t start playing when the sporting event starts. To do this, click on the New Event button. The New
Event window will appear:
a. Select Auto Start (+) from the Cue field.
b. Ensure that the time is set to “00:00” in the Time field (to ensure this comment event is the first event in the
log).
c. Select COMMENT from the Category dropdown.

d. Enter “Sports Event” (or any other text you wish) in to the Comment Text field.
e. Click OK to complete the comment event creation. Add each stopset/break definition to the clock for the first
hour: and behaviors desired.
a. Click on the New Commercial Break button and configuring the length, type, and behaviors desired.
b. Set the cue type of each break definition to “None (Start/Stop By Closure”, since each break is executed by
the closure/trigger selected in the Satellite Show Start event configured previously.
c. Set the expected time of the break in the Time field.
d. Set the length of the break in the Length field.
e. Click Next to configure any other break options you desire, and then click OK to save your changes.
f. Repeat steps a through e for each subsequent break for the hour.
NOTE: make sure the number of break definitions and their settings exactly match the break content from your
traffic system to avoid errors during the import process.Uncheck the “Merge Music Log” option at the top of the
clock editor so that music isn’t merged in to your sporting event log. Give your clock a descriptive name, such as
“Sports Hour 1” in the Description field (you can also select a display color from the Color dropdown) to
differentiate the hour-block in the Clock Builder’s grid view. After adding your desired stopset/break definitions
for the first hour, click on the OK button to close the clock editor window and return to the hour-grid view of the
Clock Builder. Double-click on the second hour-block for your sporting event to open the clock editor window.
a. Add your desired stopset/break definitions for the second hour, using the same steps performed in step 3
through 5. If your sporting event is more than two hours, you can repeat the process above for each subsequent
hour, or you can copy a previously created hour-block and paste it by left-clicking on an hour-block to highlight
it in the Clock Builder hour grid, then pressing Ctrl-C on your keyboard to copy, then left-clicking on a
subsequent hour-block and pressing Ctrl-V on your keyboard to paste.

Creating the Satellite Start Event for the Sporting Event
Next, you will need to add a Satellite Start event to your main log’s clock in Clock Builder, which will execute
the sporting event’s satellite show in OpX. To add the Satellite Start event for your sports event, double click on
the desired hour-block for the hour in which your sports event will occur in the alternate clock version of your
main clock. This will open the clock editor for your desired hour. Perform the following steps to add a Satellite
Start event:
Click on the New Satellite Show button. The Edit Satellite Show window will appear. Enter the cue, time,
name and description for the sports event:

a. Select the cue type desired. (This is most commonly a time immediate (@) cue, but if it is following another
time immediate event using an auto start (+) event will work as well).
b. Set the start time of the sporting event. Note that this is the earliest time OpX will react to the sporting event’s
game start trigger, not the time OpX will necessarily switch to the sporting event.
c. Enter a simplified name for the event in the Name field, using A-Z characters, without spaces or punctuation.
d. Enter a full name in the Description field. This is the “friendly” name visible within the program and can
include spaces, letters, numbers, and punctuation of your choice.
e. Click Next to proceed to the next page on the Edit Satellite Show window. Enter the satellite show type for
the sporting event:

a. Select Live for the satellite event type. Make sure no other type is selected.
b. Click Next to proceed to the next page on the Edit Satellite Show window. Select the closure device, start of
stop-set closure, switching, and mixer settings:

a. Select your desired closure device from the Closure Device dropdown.
b. Select the desired start of stop-set closure/trigger from the Start Commercial Break Closure dropdown.
c. If applicable to your installation, select the audio switcher settings and/or mixer settings from the Switching
and Mixer fields so that OpX can switch your audio devices to air the sporting event’s audio.
d. Click Next to proceed to the next page on the Edit Satellite Show window. Select the satellite show start
method to start by closure:

a. Select the Start By Closure option. Make sure the Start By Time option is not selected.
b. Select the closure used to start the sporting event from the Start Closure dropdown.
c. Click Next to proceed to the next page on the Edit Satellite Show window. If applicable, add any additional
audio events that will be fired by other closures (otherwise, click Next):

a. Click on the + button to add any closure-fired audio files, such as non-break station IDs (AKA “magic calls”).
b. Click Next to proceed to the next page on the Edit Satellite Show window. Select the sporting event’s end-ofgame closure:

a. Select Stop By Closure for the satellite show stop method. Make sure Stop By Length is not selected.
b. Select the end-of-game closure from the Stop On Closure dropdown.
c. Click Next to proceed to the next page on the Edit Satellite Show window. Enter the additional commands
that will be executed at the start and end of the sporting event. These commands are what stop the currently
playing audio and load the sporting event’s program log at the start of the sporting event, and load the regular
program log after the sporting event is complete:

a. In the Additional Commands To Run At Start Of Show section, click on the + button. In the Command
window that appears, enter “STOP” in the Macro Command field, and then click OK.
b. Again, In the Additional Commands To Run At Start Of Show section, click on the + button. In the
Command window that appears, enter “LOADLOG SPORTSBALL” (where “SPORTSBALL” is the name of the
secondary program log you will create containing the break content to air during the sporting event), then click
OK.
c. In the Additional Commands To Run At End Of Show section, click on the + button. In the Command
window that appears, enter “LOADLOG MAINLOG” (where “MAINLOG” is the naming format to load your
normal day’s log, such as “%mm%dd%yy”, found in your Audio Server’s program settings), then click OK.
Click OK to complete the configuration of the Edit Satellite Show window.

Importing Your Traffic Logs
For this sporting event rebroadcasting technique, you will need to generate two versions of your traffic log for
game day. You will need a full traffic log (and music log, if your station plays music) for your modified main
log, and you will need one for your sporting event log, containing the break content to play during the sporting
event.

OpX’s import configuration expects traffic logs in a specified file naming format (as configured in your import
settings). Two imports will be completed, one for the sporting event’s log, and another for the main log. Because
of this, you will need to store the main and sports traffic logs in a temporary location outside of OpX’s
configured import folder. For the sporting event’s log, you will copy your sporting event traffic log file in to
your configured import log folder and rename it to the same format as your main log’s normal import file name,
then perform the import using the sporting event’s alternate clock configured previously, then save the sporting
event’s log with the same program log name configured in step 8b in the Creating the Satellite Start Event for
the Sporting Event section. You will then need to move the sporting event’s traffic log out of the configured
import folder and copy in the main log’s traffic file and perform the standard import for the main log, but using
the modified main log’s alternate clock created previously. There are a lot of moving parts to this process, so use
the following steps to perform this task:
Create the sporting event’s program log:
a. Open the OpX Import-Merge Utility. If your OpX installation has multiple station profiles, make sure to select
the desired profile now.
b. Go to the Edit menu and choose Alternate Clocks (or Program Log Options…, depending on your version
of OpX).
c. Right-click on the date-block for the day of your sporting event and choose Set Alternate Clock from the
pop-up menu. Select the alternate clock you configured for the sporting event log (NOT the alternate main log),
then click DONE.
d. Minimize the OpX Import-Merge utility.
e. Using the Windows File Explorer, copy your sporting event traffic log into the import folder configured for
your station. Rename the log to match your normal traffic log naming format.
f. Maximize the OpX Import-Merge utility.
g. Go to the File menu and choose Import>Using Traffic Format. Your sporting event log should import
without error. If you are prompted to save changes, make sure to answer NO. The sporting event’s log needs
to be saved with your custom name configured in step 8b in the Creating the Satellite Start Event for the
Sporting Event section, but if you save it at this point the log will be saved in place of the main log.
h. Go to the File menu and choose Save As…. Enter the sporting event’s custom log name configured in step 8b
in the Creating the Satellite Start Event for the Sporting Event section into the Name field, then click on the OK
button. Create the modified main program log:
a. In the OpX Import-Merge utility, go to the Edit menu and choose Alternate Clocks (or Program Log
Options…, depending on your version of OpX).
b. Right-click on the date-block for the day of your sporting event and choose Set Alternate Clock from the
pop-up menu. Select the alternate clock you configured for the alternate main log, then click DONE.
c. Go to File>New>New Log to start with an empty log (and to ensure you don’t inadvertently save the main log
over top of the sporting event’s log)
d. Minimize the OpX Import-Merge utility.
e. Using the Windows File Explorer, delete the sporting event traffic log from the import folder configured for
your station that was copied in step 1e of this section previously. Copy your main traffic log (and music log, if
applicable) into the import folder configured for your station.
f. Maximize the OpX Import-Merge utility.
g. Perform your main log import process as you normally would (including importing your music log, if you use
one).
h. After completing your import of the main log, save it with your normal log-naming convention.
You are now done creating the logs for your sporting event (with the exception of the caveats/tips in the next
section). Your sporting event will now be rebroadcast on its configured day without any other intervention. Now,
all you have to worry about is how your favorite sportsball team performs!

Suggestions on Creating the Alternate Main Log

The above steps are the minimum needed to handle variable start/end/length sporting events. When the sporting
event concludes, your modified main log will be reloaded and will start playing from the top of the log. With
modifications to your main program log, you can add after-game content to the start of your log, or you can even
load a third after-game log instead of returning to the main log.
If you wish to return to your main log, but play after-game specific content, and then return to the normal
content intended, you can include the after game content at the top of your log. In order to skip over that content
when the log is normally loaded at midnight, simply include a time immediate event (such as a comment) before
your normal content that set to occur at midnight. When the log is first loaded just before midnight, it’ll be
skipped over because of the time immediate event. When the log is reloaded after the sporting event, the postsporting event content WON’T be skipped, since it isn’t midnight.
Including top-of-the-hour Time Next (#) or Time Immediate (@) comments for the hours after the sporting event
will cause playback of the main log to move down the program log to play the normal content that would play at
the specified time.
Alternately, if you want to use a third log, so that you go to post-game content to finish out the day, you can
create a third alternate clock in clock builder, and perform another import as outlined in this document. The
individual steps to do this are outside of the scope of this document, though.
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Please Wait!
Please wait... it will take a second!

